{"action":"Upgrade libreswan to 4.6-1 or later.","affected":[{"fixed":"4.6-1","introduced":"0"}],"component":"libreswan","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["4.6-1"],"id":"tcs_01M5NGGRQ7F1DC2K0ZBHXCA2VS","modified_at":"2026-10-15T08:02:07.978972901Z","published_at":"2022-01-15T02:15:06.547Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-23094","https://security-tracker.debian.org/tracker/CVE-2022-23094"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-23094#Debian:13/libreswan","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-23094"}],"summary":"Libreswan 4.2 through 4.5 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted IKEv1 packet because pluto/ikev1.c wrongly expects that a state"}