{"action":"Upgrade h2database to 2.1.210-1 or later.","affected":[{"fixed":"2.1.210-1","introduced":"0"}],"component":"h2database","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.1.210-1"],"id":"tcs_01M5NGGYP6R7G7934Y8PS9B7AF","modified_at":"2026-10-15T08:02:08.797284162Z","published_at":"2022-01-19T17:15:09Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-23221","https://security-tracker.debian.org/tracker/CVE-2022-23221"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-23221","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-23221"}],"summary":"H2 Console before 2.1.210 allows remote attackers to execute arbitrary code via a jdbc:h2:mem JDBC URL containing the IGNORE_UNKNOWN_SETTINGS=TRUE;FORBID_CREATION=FALSE;INIT=RUNSCRIPT substring, a dif"}