{"action":"Upgrade libowasp-esapi-java to 2.4.0.0-1 or later.","affected":[{"fixed":"2.4.0.0-1","introduced":"0"}],"component":"libowasp-esapi-java","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.4.0.0-1"],"id":"tcs_01M5NGH4MBA7KWWGEVZQBYPG98","modified_at":"2026-10-15T08:00:46.980391281Z","published_at":"2022-04-25T20:15:41.870Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-23457","https://security-tracker.debian.org/tracker/CVE-2022-23457"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-23457#Debian:13/libowasp-esapi-java","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-23457"}],"summary":"ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, the default implementation of `Validator.getValidDirectoryPath(Str"}