{"action":"Upgrade xrdp to 0.9.21.1-1 or later.","affected":[{"fixed":"0.9.21.1-1","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.9.21.1-1"],"id":"tcs_01M5NGH7EDQKW2286PBWM2X12Q","modified_at":"2026-10-15T08:02:42.387682386Z","published_at":"2022-12-09T18:15:16.153Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-23481","https://security-tracker.debian.org/tracker/CVE-2022-23481"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-23481#Debian:14/xrdp","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-23481"}],"summary":"xrdp is an open source project which provides a graphical login to remote machines using Microsoft Remote Desktop Protocol (RDP). xrdp < v0.9.21 contain a Out of Bound Read in xrdp_caps_process_confir"}