{"action":"Upgrade cyrus-sasl2 to 2.1.28+dfsg-2 or later.","affected":[{"fixed":"2.1.28+dfsg-2","introduced":"0"}],"component":"cyrus-sasl2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.1.28+dfsg-2"],"id":"tcs_01M5NGHTA99TEZA2SD41EXA007","modified_at":"2026-10-15T09:47:29.748791776Z","published_at":"2022-02-24T15:15:29.350Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-24407","https://security-tracker.debian.org/tracker/CVE-2022-24407"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-24407","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-24407"}],"summary":"In Cyrus SASL 2.1.17 through 2.1.27 before 2.1.28, plugins/sql.c does not escape the password for a SQL INSERT or UPDATE statement."}