{"action":"Upgrade ruby-image-processing to 1.10.3-2 or later.","affected":[{"fixed":"1.10.3-2","introduced":"0"}],"component":"ruby-image-processing","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.10.3-2"],"id":"tcs_01M5NGHZM6Y4XMR1R7M704BC06","modified_at":"2026-10-15T08:00:48.266261310Z","published_at":"2022-03-01T23:15:08.993Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-24720","https://security-tracker.debian.org/tracker/CVE-2022-24720"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-24720","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-24720"}],"summary":"image_processing is an image processing wrapper for libvips and ImageMagick/GraphicsMagick. Prior to version 1.12.2, using the `#apply` method from image_processing to apply a series of operations tha"}