{"action":"Upgrade libowasp-esapi-java to 2.4.0.0-1 or later.","affected":[{"fixed":"2.4.0.0-1","introduced":"0"}],"component":"libowasp-esapi-java","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.4.0.0-1"],"id":"tcs_01M5NGJF83ZHH89VB1EN2WNB3Y","modified_at":"2026-10-15T08:00:48.516541274Z","published_at":"2022-04-27T21:15:08.523Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-24891","https://security-tracker.debian.org/tracker/CVE-2022-24891"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-24891#Debian:13/libowasp-esapi-java","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-24891"}],"summary":"ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, there is a potential for a cross-site scripting vulnerability in E"}