{"action":"Upgrade node-qs to 6.10.3+ds+~6.9.7-1 or later.","affected":[{"fixed":"6.10.3+ds+~6.9.7-1","introduced":"0"}],"component":"node-qs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["6.10.3+ds+~6.9.7-1"],"id":"tcs_01M5NGJKA87YZZMZRYGW80AMWN","modified_at":"2026-10-15T08:02:43.366900331Z","published_at":"2022-11-26T22:15:10.153Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-24999","https://security-tracker.debian.org/tracker/CVE-2022-24999"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-24999","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-24999"}],"summary":"qs before 6.10.3, as used in Express before 4.17.3 and other products, allows attackers to cause a Node process hang for an Express application because an __ proto__ key can be used. In many typical E"}