{"action":"Upgrade libgoogle-gson-java to 2.9.0-1 or later.","affected":[{"fixed":"2.9.0-1","introduced":"0"}],"component":"libgoogle-gson-java","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.9.0-1"],"id":"tcs_01M5NGJYP85GP6X5HC12V8NTB9","modified_at":"2026-10-15T08:01:03.771199151Z","published_at":"2022-05-01T16:15:08.603Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-25647","https://security-tracker.debian.org/tracker/CVE-2022-25647"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-25647#Debian:13/libgoogle-gson-java","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-25647"}],"summary":"The package com.google.code.gson:gson before 2.8.9 are vulnerable to Deserialization of Untrusted Data via the writeReplace() method in internal classes, which may lead to DoS attacks."}