{"action":"Upgrade snakeyaml to 1.31-1 or later.","affected":[{"fixed":"1.31-1","introduced":"0"}],"component":"snakeyaml","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.31-1"],"id":"tcs_01M5NGK20ZRTA83YWDP77HQ2H7","modified_at":"2026-10-15T08:02:21.378277971Z","published_at":"2022-08-30T05:15:07.667Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-25857","https://security-tracker.debian.org/tracker/CVE-2022-25857"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-25857#Debian:13/snakeyaml","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-25857"}],"summary":"The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections."}