{"action":"Upgrade node-sanitize-html to 2.7.1+~2.6.2-1 or later.","affected":[{"fixed":"2.7.1+~2.6.2-1","introduced":"0"}],"component":"node-sanitize-html","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.7.1+~2.6.2-1"],"id":"tcs_01M5NGK3WSM2Y9SWFBT826NDQ4","modified_at":"2026-10-15T08:01:46.069621904Z","published_at":"2022-08-30T05:15:07.727Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-25887","https://security-tracker.debian.org/tracker/CVE-2022-25887"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-25887#Debian:14/node-sanitize-html","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-25887"}],"summary":"The package sanitize-html before 2.7.1 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure global regular expression replacement logic of HTML comment removal."}