{"action":"Upgrade node-cookiejar to 2.1.4+~2.1.2-1 or later.","affected":[{"fixed":"2.1.4+~2.1.2-1","introduced":"0"}],"component":"node-cookiejar","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.1.4+~2.1.2-1"],"id":"tcs_01M5NGK4P93F4Z02PR13RARNS5","modified_at":"2026-10-15T08:01:46.792805656Z","published_at":"2023-01-18T05:15:11.860Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-25901","https://security-tracker.debian.org/tracker/CVE-2022-25901"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-25901#Debian:13/node-cookiejar","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-25901"}],"summary":"Versions of the package cookiejar before 2.1.4 are vulnerable to Regular Expression Denial of Service (ReDoS) via the Cookie.parse function, which uses an insecure regular expression."}