{"action":"Upgrade node-ua-parser-js to 0.8.1+ds+~0.7.36-3 or later.","affected":[{"fixed":"0.8.1+ds+~0.7.36-3","introduced":"0"}],"component":"node-ua-parser-js","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.8.1+ds+~0.7.36-3"],"id":"tcs_01M5NGK520926NQP7DMZPX956E","modified_at":"2026-10-15T08:02:15.345319846Z","published_at":"2023-01-26T21:15:32.107Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-25927","https://security-tracker.debian.org/tracker/CVE-2022-25927"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-25927#Debian:14/node-ua-parser-js","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-25927"}],"summary":"Versions of the package ua-parser-js from 0.7.30 and before 0.7.33, from 0.8.1 and before 1.0.33 are vulnerable to Regular Expression Denial of Service (ReDoS) via the trim() function."}