{"action":"Upgrade pdns to 4.6.1-1 or later.","affected":[{"fixed":"4.6.1-1","introduced":"0"}],"component":"pdns","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["4.6.1-1"],"id":"tcs_01M5NGM6D493V57HFH2FFCSXPS","modified_at":"2026-10-15T08:02:28.396478902Z","published_at":"2022-03-25T15:15:07.697Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-27227","https://security-tracker.debian.org/tracker/CVE-2022-27227"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-27227#Debian:14/pdns","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-27227"}],"summary":"In PowerDNS Authoritative Server before 4.4.3, 4.5.x before 4.5.4, and 4.6.x before 4.6.1 and PowerDNS Recursor before 4.4.8, 4.5.x before 4.5.8, and 4.6.x before 4.6.1, insufficient validation of an"}