{"action":"Upgrade weechat to 3.4.1-1 or later.","affected":[{"fixed":"3.4.1-1","introduced":"0"}],"component":"weechat","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["3.4.1-1"],"id":"tcs_01M5NGN1RMHF6HWMZVA71Q92NM","modified_at":"2026-11-03T08:01:12.590436137Z","published_at":"2022-04-02T17:15:07.997Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-28352","https://security-tracker.debian.org/tracker/CVE-2022-28352"],"severity":{"label":"medium","score":4.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-28352#Debian:13/weechat","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-28352"}],"summary":"WeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify the TLS certificate of the server, after certain GnuTLS options are changed, which allows man-in-the-mi"}