{"action":"Upgrade ruby2.7 to 2.7.4-1+deb11u2 or later.","affected":[{"fixed":"2.7.4-1+deb11u2","introduced":"0"}],"component":"ruby2.7","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["2.7.4-1+deb11u2"],"id":"tcs_01M5NGND5RCYXE7GDEHBZ4M4MW","modified_at":"2026-08-27T23:04:44.542651266Z","published_at":"2022-05-09T18:15:08.540Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-28739","https://security-tracker.debian.org/tracker/CVE-2022-28739"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-28739","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-28739"}],"summary":"There is a buffer over-read in Ruby before 2.6.10, 2.7.x before 2.7.6, 3.x before 3.0.4, and 3.1.x before 3.1.2. It occurs in String-to-Float conversion, including Kernel#Float and String#to_f."}