{"action":"Upgrade lua5.4 to 5.4.4-2 or later.","affected":[{"fixed":"5.4.4-2","introduced":"0"}],"component":"lua5.4","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.4.4-2"],"id":"tcs_01M5NGNDYQ7TR2YDPZRJGAJSCY","modified_at":"2026-10-15T08:02:22.896842953Z","published_at":"2022-04-08T06:15:07.243Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-28805","https://security-tracker.debian.org/tracker/CVE-2022-28805"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-28805#Debian:14/lua5.4","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-28805"}],"summary":"singlevar in lparser.c in Lua from (including) 5.4.0 up to (excluding) 5.4.4 lacks a certain luaK_exp2anyregup call, leading to a heap-based buffer over-read that might affect a system that compiles u"}