{"action":"Upgrade smarty4 to 4.1.1-1 or later.","affected":[{"fixed":"4.1.1-1","introduced":"0"}],"component":"smarty4","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["4.1.1-1"],"id":"tcs_01M5NGNP7Q18VK2F7SVRXYJ5B6","modified_at":"2026-10-15T08:01:13.268569451Z","published_at":"2022-05-24T15:15:07.917Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-29221","https://security-tracker.debian.org/tracker/CVE-2022-29221"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-29221#Debian:13/smarty4","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-29221"}],"summary":"Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.45 and 4.1.1, template authors could inject php code by choosi"}