{"action":"Upgrade maven-shared-utils to 3.3.4-1 or later.","affected":[{"fixed":"3.3.4-1","introduced":"0"}],"component":"maven-shared-utils","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["3.3.4-1"],"id":"tcs_01M5NGNXKY267VB30E57ETEDPR","modified_at":"2026-10-15T08:03:04.401899687Z","published_at":"2022-05-23T11:16:10.877Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-29599","https://security-tracker.debian.org/tracker/CVE-2022-29599"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-29599#Debian:13/maven-shared-utils","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-29599"}],"summary":"In Apache Maven maven-shared-utils prior to version 3.3.3, the Commandline class can emit double-quoted strings without proper escaping, allowing shell injection attacks."}