{"action":"Upgrade ruby-rack to 2.2.4-1 or later.","affected":[{"fixed":"2.2.4-1","introduced":"0"}],"component":"ruby-rack","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.2.4-1"],"id":"tcs_01M5NGPE7G54TSRYTNNVQ3K6BH","modified_at":"2026-10-15T08:02:52.921075151Z","published_at":"2022-12-05T22:15:10.280Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-30123","https://security-tracker.debian.org/tracker/CVE-2022-30123"],"severity":{"label":"critical","score":10},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-30123#Debian:14/ruby-rack","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-30123"}],"summary":"A sequence injection vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 which could allow is a possible shell escape in the Lint and CommonLogger components of Rack."}