{"action":"Upgrade needrestart to 3.6-1 or later.","affected":[{"fixed":"3.6-1","introduced":"0"}],"component":"needrestart","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["3.6-1"],"id":"tcs_01M5NGPWKESG29B3Z84WZE49JC","modified_at":"2026-10-15T08:01:49.911900392Z","published_at":"2022-05-17T19:15:08.743Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-30688","https://security-tracker.debian.org/tracker/CVE-2022-30688"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-30688","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-30688"}],"summary":"needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges"}