{"action":"Upgrade linux to 5.16.18-1 or later.","affected":[{"fixed":"5.16.18-1","introduced":"0"}],"component":"linux","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.16.18-1"],"id":"tcs_01M5NGQ8QCS0SJ2BGKJZKAGE97","modified_at":"2026-10-15T08:01:50.355946986Z","published_at":"2022-12-14T21:15:11.943Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-3107","https://security-tracker.debian.org/tracker/CVE-2022-3107"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-3107#Debian:14/linux","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-3107"}],"summary":"An issue was discovered in the Linux kernel through 5.16-rc6. netvsc_get_ethtool_stats in drivers/net/hyperv/netvsc_drv.c lacks check of the return value of kvmalloc_array() and will cause the null po"}