{"action":"Upgrade node-mermaid to 9.2.2+~2.0.0-1 or later.","affected":[{"fixed":"9.2.2+~2.0.0-1","introduced":"0"}],"component":"node-mermaid","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["9.2.2+~2.0.0-1"],"id":"tcs_01M5NGQD4CBV3HNYXT2EXAY20E","modified_at":"2026-10-15T08:02:38.774812017Z","published_at":"2022-06-28T19:15:09.423Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-31108","https://security-tracker.debian.org/tracker/CVE-2022-31108"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-31108","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-31108"}],"summary":"Mermaid is a JavaScript based diagramming and charting tool that uses Markdown-inspired text definitions and a renderer to create and modify complex diagrams. An attacker is able to inject arbitrary `"}