{"action":"Upgrade rust-hyper to 0.14.19-1 or later.","affected":[{"fixed":"0.14.19-1","introduced":"0"}],"component":"rust-hyper","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.14.19-1"],"id":"tcs_01M5NGQJXXFPYCTNCMT056N2S6","modified_at":"2026-10-15T08:02:53.066142032Z","published_at":"2023-02-21T14:15:13.363Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-31394","https://security-tracker.debian.org/tracker/CVE-2022-31394"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-31394","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-31394"}],"summary":"Hyperium Hyper before 0.14.19 does not allow for customization of the max_header_list_size method in the H2 third-party software, allowing attackers to perform HTTP2 attacks."}