{"action":"Upgrade libjpeg to 0.0~git20220615.842c7ba-1 or later.","affected":[{"introduced":"0"}],"component":"libjpeg","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.0~git20220615.842c7ba-1"],"id":"tcs_01M5NGQNRNJY8A683EX25AYFYY","modified_at":"2026-10-15T08:02:29.954840847Z","published_at":"2022-05-25T21:15:08.530Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-31620","https://security-tracker.debian.org/tracker/CVE-2022-31620"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-31620","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-31620"}],"summary":"In libjpeg before 1.64, BitStream<false>::Get in bitstream.hpp has an assertion failure that may cause denial of service. This is related to out-of-bounds array access during arithmetically coded loss"}