{"action":"Upgrade nodejs to 18.6.0+dfsg-3 or later.","affected":[{"fixed":"18.6.0+dfsg-3","introduced":"0"}],"component":"nodejs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["18.6.0+dfsg-3"],"id":"tcs_01M5NGR8W2CZ02N8FQJP1PHCEP","modified_at":"2026-10-15T08:02:43.527533915Z","published_at":"2022-07-14T15:15:08.237Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-32212","https://security-tracker.debian.org/tracker/CVE-2022-32212"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-32212#Debian:14/nodejs","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-32212"}],"summary":"A OS Command Injection vulnerability exists in Node.js versions <14.20.0, <16.20.0, <18.5.0 due to an insufficient IsAllowedHost check that can easily be bypassed because IsIPAddress does not properly"}