{"action":"Upgrade protobuf to 3.21.9-3 or later.","affected":[{"fixed":"3.21.9-3","introduced":"0"}],"component":"protobuf","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.21.9-3"],"id":"tcs_01M5NGTJFJ401VE2QEKH6V1JRA","modified_at":"2026-11-03T08:04:08.763867221Z","published_at":"2022-12-12T13:15:14.670Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-3510","https://security-tracker.debian.org/tracker/CVE-2022-3510"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-3510#Debian:14/protobuf","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-3510"}],"summary":"A parsing issue similar to CVE-2022-3171, but with Message-Type Extensions in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. In"}