{"action":"Upgrade knot-resolver to 5.5.3-1 or later.","affected":[{"fixed":"5.5.3-1","introduced":"0"}],"component":"knot-resolver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.5.3-1"],"id":"tcs_01M5NGXT3V2H9519Q2D9N34ZQM","modified_at":"2026-11-03T08:02:54.846782786Z","published_at":"2022-09-23T16:15:11.673Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-40188","https://security-tracker.debian.org/tracker/CVE-2022-40188"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-40188#Debian:14/knot-resolver","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-40188"}],"summary":"Knot Resolver before 5.5.3 allows remote attackers to cause a denial of service (CPU consumption) because of algorithmic complexity. During an attack, an authoritative server must return large NS sets"}