{"action":"Upgrade wolfssl to 5.5.3-1 or later.","affected":[{"fixed":"5.5.3-1","introduced":"0"}],"component":"wolfssl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["5.5.3-1"],"id":"tcs_01M5NH04BVN3AM1HQ8NPDA7JE9","modified_at":"2026-10-15T08:02:45.502679081Z","published_at":"2022-11-07T00:15:09.643Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-42905","https://security-tracker.debian.org/tracker/CVE-2022-42905"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-42905","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-42905"}],"summary":"In wolfSSL before 5.5.2, if callback functions are enabled (via the WOLFSSL_CALLBACKS flag), then a malicious TLS 1.3 client or network attacker can trigger a buffer over-read on the heap of 5 bytes."}