{"action":"Upgrade nodejs to 18.12.1+dfsg-1 or later.","affected":[{"fixed":"18.12.1+dfsg-1","introduced":"0"}],"component":"nodejs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["18.12.1+dfsg-1"],"id":"tcs_01M5NH0NVV7JD4SFYD21YDAASS","modified_at":"2026-10-15T08:03:09.798577916Z","published_at":"2022-12-05T22:15:10.923Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-43548","https://security-tracker.debian.org/tracker/CVE-2022-43548"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-43548","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-43548"}],"summary":"A OS Command Injection vulnerability exists in Node.js versions <14.21.1, <16.18.1, <18.12.1, <19.0.1 due to an insufficient IsAllowedHost check that can easily be bypassed because IsIPAddress does no"}