{"action":"Upgrade samba to 2:4.17.4+dfsg-1 or later.","affected":[{"fixed":"2:4.17.4+dfsg-1","introduced":"0"}],"component":"samba","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2:4.17.4+dfsg-1"],"id":"tcs_01M5NH17XMV5RT0210Z7302ZZA","modified_at":"2026-10-15T08:02:46.320505985Z","published_at":"2022-12-25T05:15:11.103Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-44640","https://security-tracker.debian.org/tracker/CVE-2022-44640"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-44640#Debian:12/samba","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-44640"}],"summary":"Heimdal before 7.7.1 allows remote attackers to execute arbitrary code because of an invalid free in the ASN.1 codec used by the Key Distribution Center (KDC)."}