{"action":"Upgrade linux to 5.19.6-1 or later.","affected":[{"fixed":"5.19.6-1","introduced":"0"}],"component":"linux","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["5.19.6-1"],"id":"tcs_01M5NH34NQTGFRKWP5C0DHTEQM","modified_at":"2026-10-15T08:02:33.251414255Z","published_at":"2022-12-23T16:15:12.533Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2022-47940","https://security-tracker.debian.org/tracker/CVE-2022-47940"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2022-47940#Debian:13/linux","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2022-47940"}],"summary":"An issue was discovered in ksmbd in the Linux kernel 5.15 through 5.18 before 5.18.18. fs/ksmbd/smb2pdu.c lacks length validation in the non-padding case in smb2_write."}