{"action":"Upgrade apache-jena to 4.9.0-1 or later.","affected":[{"fixed":"4.9.0-1","introduced":"0"}],"component":"apache-jena","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["4.9.0-1"],"id":"tcs_01M5NHWCZ86V9PY67CGC2SKR6Y","modified_at":"2026-10-26T18:01:36.228678988Z","published_at":"2023-04-25T07:15:08.137Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-22665","https://security-tracker.debian.org/tracker/CVE-2023-22665"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-22665#Debian:13/apache-jena","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-22665"}],"summary":"There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query."}