{"action":"Upgrade apache-jena to 4.9.0-1 or later.","affected":[{"fixed":"4.9.0-1","introduced":"0"}],"component":"apache-jena","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["4.9.0-1"],"id":"tcs_01M5NHWD24MW6QDEAS3XYQV3Y5","modified_at":"2026-10-23T18:04:51.628137719Z","published_at":"2023-04-25T07:15:08.137Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-22665","https://security-tracker.debian.org/tracker/CVE-2023-22665"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-22665#Debian:14/apache-jena","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-22665"}],"summary":"There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query."}