{"action":"Upgrade sudo to 1.9.12p2-1 or later.","affected":[{"fixed":"1.9.12p2-1","introduced":"0"}],"component":"sudo","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.9.12p2-1"],"id":"tcs_01M5NHWG4F8E2JFE2QPH0MMCTB","modified_at":"2026-10-23T18:04:22.374793617Z","published_at":"2023-01-18T17:15:10.353Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-22809","https://security-tracker.debian.org/tracker/CVE-2023-22809"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-22809","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-22809"}],"summary":"In Sudo before 1.9.12p2, the sudoedit (aka -e) feature mishandles extra arguments passed in the user-provided environment variables (SUDO_EDITOR, VISUAL, and EDITOR), allowing a local attacker to appe"}