{"action":"Upgrade tor to 0.4.7.13-1 or later.","affected":[{"fixed":"0.4.7.13-1","introduced":"0"}],"component":"tor","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.4.7.13-1"],"id":"tcs_01M5NHWWGX74T29BPKKSAMK24Z","modified_at":"2026-10-26T18:00:32.584087313Z","published_at":"2023-01-14T01:15:15.627Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-23589","https://security-tracker.debian.org/tracker/CVE-2023-23589"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-23589#Debian:13/tor","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-23589"}],"summary":"The SafeSocks option in Tor before 0.4.7.13 has a logic error in which the unsafe SOCKS4 protocol can be used but not the safe SOCKS4a protocol, aka TROVE-2022-002."}