{"action":"Upgrade node-follow-redirects to 1.15.6+~1.14.4-1 or later.","affected":[{"fixed":"1.15.6+~1.14.4-1","introduced":"0"}],"component":"node-follow-redirects","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.15.6+~1.14.4-1"],"id":"tcs_01M5NHYQES7YH8EB89AP35HN7B","modified_at":"2026-10-26T18:02:10.757944417Z","published_at":"2024-01-02T05:15:08.630Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-26159","https://security-tracker.debian.org/tracker/CVE-2023-26159"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-26159#Debian:13/node-follow-redirects","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-26159"}],"summary":"Versions of the package follow-redirects before 1.15.4 are vulnerable to Improper Input Validation due to the improper handling of URLs by the url.parse() function. When new URL() throws an error, it"}