{"action":"Upgrade node-webpack to 5.75.0+dfsg+~cs17.16.14-1+deb12u1 or later.","affected":[{"fixed":"5.75.0+dfsg+~cs17.16.14-1+deb12u1","introduced":"0"}],"component":"node-webpack","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["5.75.0+dfsg+~cs17.16.14-1+deb12u1"],"id":"tcs_01M5NHZNHPC2Q68P4RQQH8E85Q","modified_at":"2026-10-23T18:05:23.915011004Z","published_at":"2023-03-13T01:15:10.053Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-28154","https://security-tracker.debian.org/tracker/CVE-2023-28154"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-28154","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-28154"}],"summary":"Webpack 5 before 5.76.0 does not avoid cross-realm object access. ImportParserPlugin.js mishandles the magic comment feature. An attacker who controls a property of an untrusted object can obtain acce"}