{"action":"Upgrade openssh to 1:9.3p1-1 or later.","affected":[{"fixed":"1:9.3p1-1","introduced":"0"}],"component":"openssh","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1:9.3p1-1"],"id":"tcs_01M5NJ015FRN4KNTBFRWBFWHT4","modified_at":"2026-10-15T09:47:33.527805095Z","published_at":"2023-03-17T04:15:14.553Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-28531","https://security-tracker.debian.org/tracker/CVE-2023-28531"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-28531#Debian:14/openssh","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-28531"}],"summary":"ssh-add in OpenSSH before 9.3 adds smartcard keys to ssh-agent without the intended per-hop destination constraints. The earliest affected version is 8.9."}