{"action":"Upgrade libgitlab-api-v4-perl to 0.27-1 or later.","affected":[{"fixed":"0.27-1","introduced":"0"}],"component":"libgitlab-api-v4-perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.27-1"],"id":"tcs_01M5NJ1VBN2RHDTG5NPVQCGEPF","modified_at":"2026-10-26T18:01:24.579256215Z","published_at":"2023-04-29T00:15:09.043Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-31485","https://security-tracker.debian.org/tracker/CVE-2023-31485"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-31485#Debian:14/libgitlab-api-v4-perl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-31485"}],"summary":"GitLab::API::v4 through 0.26 does not verify TLS certificates when connecting to a GitLab server, enabling machine-in-the-middle attacks."}