{"action":"Upgrade libjose4j-java to 0.7.12-2 or later.","affected":[{"fixed":"0.7.12-2","introduced":"0"}],"component":"libjose4j-java","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.7.12-2"],"id":"tcs_01M5NJ1YVEA6XH616HB2X1NSSA","modified_at":"2026-10-26T18:00:56.768379883Z","published_at":"2023-10-25T18:17:27.777Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-31582","https://security-tracker.debian.org/tracker/CVE-2023-31582"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-31582#Debian:14/libjose4j-java","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-31582"}],"summary":"jose4j before v0.9.3 allows attackers to set a low iteration count of 1000 or less."}