{"action":"Upgrade node-socket.io-parser to 4.2.1+~3.1.0-2 or later.","affected":[{"fixed":"4.2.1+~3.1.0-2","introduced":"0"}],"component":"node-socket.io-parser","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.2.1+~3.1.0-2"],"id":"tcs_01M5NJ32Z7SZ9FDSV7JTHJP2CT","modified_at":"2026-10-23T18:04:25.069722340Z","published_at":"2023-05-27T16:15:09.433Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-32695","https://security-tracker.debian.org/tracker/CVE-2023-32695"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-32695","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-32695"}],"summary":"socket.io parser is a socket.io encoder and decoder written in JavaScript complying with version 5 of socket.io-protocol. A specially crafted Socket.IO packet can trigger an uncaught exception on the"}