{"action":"Upgrade swupdate to 2024.12+dfsg-1 or later.","affected":[{"fixed":"2024.12+dfsg-1","introduced":"0"}],"component":"swupdate","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2024.12+dfsg-1"],"id":"tcs_01M5NJ3P8HBK4EG64SJPEQ8D92","modified_at":"2026-10-26T18:02:29.034175427Z","published_at":"2023-06-23T20:15:09.053Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-34188","https://security-tracker.debian.org/tracker/CVE-2023-34188"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-34188#Debian:14/swupdate","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-34188"}],"summary":"The HTTP server in Mongoose before 7.10 accepts requests containing negative Content-Length headers. By sending a single attack payload over TCP, an attacker can cause an infinite loop in which the se"}