{"action":"Upgrade opennds to 10.2.0+dfsg-1 or later.","affected":[{"fixed":"10.2.0+dfsg-1","introduced":"0"}],"component":"opennds","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["10.2.0+dfsg-1"],"id":"tcs_01M5NJ6135M14TZHSBWAG619PH","modified_at":"2026-10-26T18:02:30.198000923Z","published_at":"2023-11-17T06:15:33.530Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-38314","https://security-tracker.debian.org/tracker/CVE-2023-38314"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-38314#Debian:13/opennds","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-38314"}],"summary":"An issue was discovered in OpenNDS Captive Portal before version 10.1.2. It has a NULL pointer dereference in preauthenticated() that can be triggered with a crafted GET HTTP request with a missing re"}