{"action":"Upgrade gtkwave to 3.3.118-0.1 or later.","affected":[{"fixed":"3.3.118-0.1","introduced":"0"}],"component":"gtkwave","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["3.3.118-0.1"],"id":"tcs_01M5NJ6CHTSMDPA5GN8ZW3KJHS","modified_at":"2026-10-26T18:03:06.161550608Z","published_at":"2024-01-08T15:15:19.187Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-38583","https://security-tracker.debian.org/tracker/CVE-2023-38583"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-38583#Debian:13/gtkwave","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-38583"}],"summary":"A stack-based buffer overflow vulnerability exists in the LXT2 lxt2_rd_expand_integer_to_bits function of GTKWave 3.3.115. A specially crafted .lxt2 file can lead to arbitrary code execution. A victim"}