{"action":"Upgrade fastdds to 2.9.1+ds-1+deb12u1 or later.","affected":[{"fixed":"2.9.1+ds-1+deb12u1","introduced":"0"}],"component":"fastdds","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.9.1+ds-1+deb12u1"],"id":"tcs_01M5NJ7NQEBRZXVV3CXFC6Y1Y2","modified_at":"2026-10-26T18:02:31.456970361Z","published_at":"2023-08-11T14:15:13.483Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-39946","https://security-tracker.debian.org/tracker/CVE-2023-39946"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-39946","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-39946"}],"summary":"eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.11.1, 2.10.2, 2.9.2, and 2.6.6, heap can be overflowed by provid"}