{"action":"Upgrade puma to 5.6.7-1 or later.","affected":[{"fixed":"5.6.7-1","introduced":"0"}],"component":"puma","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.6.7-1"],"id":"tcs_01M5NJ7TH0XYTFF9S8WCPM8N7W","modified_at":"2026-10-26T18:02:31.925551770Z","published_at":"2023-08-18T22:15:11.653Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-40175","https://security-tracker.debian.org/tracker/CVE-2023-40175"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-40175#Debian:14/puma","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-40175"}],"summary":"Puma is a Ruby/Rack web server built for parallelism. Prior to versions 6.3.1 and 5.6.7, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies and zero-length Content-Length"}