{"action":"Upgrade xrdp to 0.9.21.1-1+deb12u1 or later.","affected":[{"fixed":"0.9.21.1-1+deb12u1","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.9.21.1-1+deb12u1"],"id":"tcs_01M5NJ7TQCJ5CB9B3EF97WVD4S","modified_at":"2026-10-26T18:02:32.444289893Z","published_at":"2023-08-30T18:15:09.690Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-40184","https://security-tracker.debian.org/tracker/CVE-2023-40184"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-40184","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-40184"}],"summary":"xrdp is an open source remote desktop protocol (RDP) server. In versions prior to 0.9.23 improper handling of session establishment errors allows bypassing OS-level session restrictions. The `auth_sta"}