{"action":"Upgrade opennds to 10.2.0+dfsg-1 or later.","affected":[{"fixed":"10.2.0+dfsg-1","introduced":"0"}],"component":"opennds","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["10.2.0+dfsg-1"],"id":"tcs_01M5NJ8P6JN2Y05JP6QF0HCD65","modified_at":"2026-10-26T18:02:32.409778106Z","published_at":"2023-11-17T06:15:34.137Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-41101","https://security-tracker.debian.org/tracker/CVE-2023-41101"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-41101#Debian:13/opennds","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-41101"}],"summary":"An issue was discovered in the captive portal in OpenNDS before version 10.1.3. get_query in http_microhttpd.c does not validate the length of the query string of GET requests. This leads to a stack-b"}