{"action":"Upgrade node-ip to 2.0.1+~1.1.3-1 or later.","affected":[{"fixed":"2.0.1+~1.1.3-1","introduced":"0"}],"component":"node-ip","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.0.1+~1.1.3-1"],"id":"tcs_01M5NJ94EP3JWD5KFPARXHQKHW","modified_at":"2026-10-26T18:00:12.442592161Z","published_at":"2024-02-08T17:15:10.840Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2023-42282","https://security-tracker.debian.org/tracker/CVE-2023-42282"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2023-42282#Debian:14/node-ip","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2023-42282"}],"summary":"The ip package before 1.1.9 for Node.js might allow SSRF because some IP addresses (such as 0x7f.1) are improperly categorized as globally routable via isPublic."}